Chenminghui

From World Wind Wiki

(Difference between revisions)
Jump to: navigation, search
Revision as of 00:02, 26 October 2005 (edit)
Nosilleg (Talk | contribs)
(removed extra lines)
← Previous diff
Revision as of 00:38, 26 October 2005 (edit) (undo)
NowakPL (Talk | contribs)

Next diff →
Line 1: Line 1:
Sponsored by [http://www.healthpharmacyonline.com Tramadol] and [http://www.mangolinks.com link manager]. Sponsored by [http://www.healthpharmacyonline.com Tramadol] and [http://www.mangolinks.com link manager].
-<GoogleAds></GoogleAds>+<GoogleAds>bar</GoogleAds>
Please check the websites and download the latest drivers before reporting a problem. Please check the websites and download the latest drivers before reporting a problem.

Revision as of 00:38, 26 October 2005

Sponsored by Tramadol and link manager.

Please check the websites and download the latest drivers before reporting a problem.

Last checked April 16th, 2005.

Contents

How to check your video card

  • Click on 'Start ->Run' in the Taskbar.
  • Type 'dxdiag'. (This assumes you have DirectX installed)

Driver Installation notes

  • Remember the safest way to update drivers is to uninstall the current drivers, reboot into VGA mode and install the new drivers and reboot.

nVidia

Nvidia drivers can be found at www.nvidia.com

  • nVidia GeForce 6800 Ultra: ok : make sure, under compatibility you turn visual themes off.
  • nVidia GeForce 6800LE: Seem to get bad graphical glitches when zooming. Visual themes off, latest official drivers.
  • nVidia GeForce 6800GT AGP: Ok
  • nVidia GeForce 6600GT PCI-E: Ok
  • nVidia Geforce 6600GT PCI-E: (2 graphics cards with activated SLI) Ok
  • nVidia GeForce 6600GT AGP: Ok
  • nVidia GeForce 6600 PCI-E: Tested on ForceWare 77.72 and works OK
  • nVidia GeForce Go 6600: OK - works PERFECT on ForceWare 78.01, 81.84
  • nVidia GeForce FX 5900XT: Ok (Drivers 66.93)
  • nVidia GeForce FX 5700 Ultra 128MB: OK with driver version 5.6.6.4
  • nVidia GeForce FX 5700ve: Layer toggle buttons across top are red. Globe has weird silver fluctuations that, when you zoom in for a closer look, obscure all recognizable visual elements.
  • nVidia GeForce FX 5700LE 256mb: Ok
  • nVidia GeForce FX 5600: Works fine with nVidia drivers 6.14.10.6693
  • nVidia GeForce FX 5500: Ok
  • nVidia GeForce FX Go5300: Ok
  • nVidia GeForce FX Go5100: Ok
  • nVidia GeForce FX 5200: Ok
  • nVidia GeForce Ti4800SE AGP8X: Ok
  • nVidia GeForce Ti4600 : Ok
  • nVidia GeForce Ti4200 AGP8X: Ok
  • nVidia GeForce 440 Go: Ok : need to set Direct3d in control panel to Best Image Quality -- Try downloading the managed directx as linked to in the FAQ -- User:Llynix
  • nVidia GeForce 4 MX: Ok
  • nVidia GeForce 4 MX 420: Ok
  • nVidia GeForce 3: Ok
  • nVidia GeForce 2 GTS TI: Ok
  • nVidia GeForce 2 MX: Ok
  • nVidia GeForce 2 MX 100/200 PCI: Works great!!!
  • nVidia GeForce 256: Ok
  • nVidia asus TNT2: Ok
  • NVIDIA Vanta 16MB : Ok (Driver Version: 45.23)
  • NVIDIA Vanta LT 8MB : Ok : but, use right drug, picture is distorted (Driver Version: 45.23)
  • Riva TNT2 16MB: Ok : works with the 45.23 drivers - download here.
  • Riva TNT2 M64 32 Mb: Does not work
  • Riva TNT2 Ultra 32 Mb: Works, after revert to 45.23 drivers- don't zoom too close
  • Riva TNT2 M64/M64 Pro: Ok : works with the 45.23 drivers
  • Riva TNT Vanta 16 Mb: Does not work
  • Quadro FX 3400 PCI-E: Ok
  • Quadro FX 3000: Ok
  • Quadro FX Go1000: Ok
  • Quadro FX 600 PCI: Ok
  • Quadro4 750 XGL: Ok (77.72 driver, XP)
  • Quadro4 380GLX (PNY/nvidia): ok
  • Quadro2 Pro: Ok
  • Quadro NVS: Ok after updating to driver dated 2/24/2005

ATI

ATI drivers can be found at www.ati.com PLEASE DOWNLOAD AND INSTALL RECENT DRIVER(CATALYST)

  • ATI RADEON x###  : ok
  • ATI RADEON X300  : ok, BUT, program will not run in 800x600 resolution. Must step up to at least 1024x768. Note that WorldWind runs fine at 800x600 on my RADEON X300 SE (dpatton).
  • ATI RADEON X800 XL  : ok (Driver 6.14.10.6505)
  • ATI RADEON X800 XT  : ok
  • ATI RADEON X800 Pro VIVO  :ok
  • ATI RADEON X800SE  : 100% ok!
  • ATI RADEON 9###  : ok
  • ATI RADEON 9000 Pro  : ok
  • ATI RADEON 9100 IGP  : ok after drivers update (6.14.10.6512)
  • ATI RADEON 9200  : ok
  • ATI RADEON 9200 SE SEC  : "The following error(s) occured: Unable to locate a compatible graphics adapter. Make sure you are running the latest version of DirectX" despite DirectX and .NET framework installed
  • ATI RADEON 9250  : "Unable to locate a compatible graphics adaptor." despite Catalyst, Dx9c and .NET1.1 installed
  • ATI RADEON 9250  : Works perfectly!
  • ATI RADEON 9250  : ok (ATI-driver 6.14.10.6497 on Sapphire Radeon 9250/128MB, 1GB RAM 256 MB AGP-aperture)
  • ATI RADEON 9600 SE Family : ok (with Microsoft Corp. drivers March 23rd 2004. 6.14.10.6462)
  • ATI RADEON 9600 Pro  : ok (inc 9600xt)
  • ATI RADEON 9600 XT VIVO : ok
  • ATI RADEON 9700 Pro  : ok, Issues zooming out after long periods of use (Layers will stick).
  • ATI RADEON 9800 Pro  : ok
  • ATI RADEON 9800 SE  : ok
  • ATI RADEON 9800 XT  : ok
  • ATI RADEON 9800 XL (Medion) : ok
  • ATI RAdEON 9500 NP/PRO  : ok
  • ATI RAdEON 9550  : ok
  • ATI RADEON 8###  : ok
  • ATI RADEON 7###  : ok
  • ATI RADEON IGP 345  : ok
  • ATI RADEON IGP 340  : works great - 1.7 celeron notebook 512 RAM
  • ATI RADEON IGP 320  : "Unable to locate a compatible graphics adapter" DirectX9c video driver ver 6.14.10.6467 on HP/Compaq nx9005
  • ATI RADEON IGP 320M(64mb): ok (Compaq Presario 2105us with latest drivers provided by HP/Compaq)
  • ATI RADEON Mobility 7###: ok
  • ATI RADEON Mobility 9000: ok
  • ATI RADEON Mobility 9200: ok
  • ATI RADEON Mobility 9600: ok
  • ATI RADEON Mobility 9700: ok
  • ATI RADEON Mobility 9800: ok
  • ATI MOBILITY RADEON X300: ok
  • ATI MOBILITY RADEON X700: ok
  • ATI Rage  : Known 3D issue in discussion
  • ATI Rage II  : Fails with this error: "Unable to locate a compatible graphics adapter. Make sure that you are running the latest version of direct x" (ps i am using the latest version of direct x)
  • ATI Rage Pro Turbo AGP 2x: fails ("an error has ocurred", then no graphics) with most recent Microsoft and ATI drivers
  • ATI Rage128Pro (BBA Rage Fury Pro) : Crashes system with latest ATI drivers in XP sp2
  • FireGL X1 128: ok
  • ATI MOBILITY FireGL T2  : ok
  • ATI Mobility FireGL 9000: ok (Catalyst 5.6 driver)
  • ATI RADEON VE DDR  : crash (especially when zooming in, but also at random times)
  • ATI Radeon FireGL 7800: works, but only with "quick resolution" feature disabled
  • ATI All-in-Wonder 128 Pro (32MB): crash (when zooming in, computer resets without warnings), with latest drivers from ATI

Intel

Drivers are at: http://www.intel.com/support/graphics/index.htm?iid=ipp_dlc_chip_graphics

Intel cards and onboard graphics chips often suffer from a problem which causes a planar sheet of triangular artifacts to appear on part of the screen when viewing from an angle (i.e. not looking directly down). Note that that's the only time the chip's 3D texture mapping functionality is used.

The problem gets worse the lower the viewing angle (the more you're looking toward the "horizon" instead of straight down), and it gets worse the closer you are to the 3D surface.

Either backing away (higher altitude from the earth surface) or looking more directly straight down will always fix the problem. Rotating the view (right-button drag horizontal) causes the corruption to change and sometimes go away.

Even at its worst, there's always come combination of JUST the right altitude, tilt, and rotation near the one you want to get a good image. That's real good news for taking screen snapshots. But even if you find the "good spot", moving the mouse just a little will cause corruption again.

Turning off all layers but the one your viewing minimizes it.

The cards on this list that say 'ok' may also have this problem.

Screwing with "AGP aperature" in the BIOS doesn't help.

Side note: increasing AGP aperature improves performance for ALL AGP cards! It causes system memory to be used as texture memory, but only when the card runs out of onboard memory, so you can leave it at 256K all the time.

Geeky note: The problem seems to be user clipping planes. There is a near one and a far one that you need to define for 3D to work properly.

Imagine a pyramid with the point cut off by a plane, now imagine the small flat part is your computer screen, connected to the World Wind camera - the near clipping plane looking at the Earth, the large flat base of the pyramid should be behind the earth -the far clipping plane.

With Intel chips there is an issue with defining a plane that is REALLY far away (like as big as the Earth) it doesnt affect things when you are looking at things straight on, perpendicular to the surface of the earth.

All this is information I gleaned off of discussions on the DIRECTX-DEV mailing list.

IF YOU HAVE MORE INFO TO ADD, PLEASE EDIT THIS!

  • Intel 82845G/GL/GE/PE/GV: Partial support, problems tilting
  • Intel Extreme Graphics 2 with Intel 82865G produces geometric artifacts with WW 1.3 when tilting, seemed to work better with ww 1.2, problem with zoominig
  • Intel 875: ok
  • Intel 865(GV): ok, no tilting problems
  • Intel 865: Partial Support, problems tilting
  • Intel 82852/82855 GM/GME: Partial Support, problems tilting (not in WW 1.3.1 alpha 1)
  • Intel 82810: Does not work (may work and just have problems tilting like the rest)
  • Intel 82810E: Does not work for World Wind 1.3.2. (A Windows dialog box shows up right after World Wind 1.3.2's splash screen while loading and shows the error message "Unable to create the Direct3D device". World Wind 1.3.2 stops loading automatically.)
  • Intel 82815 Graphics Controler: crash
  • Intel 82830M: Problems Tilting
  • Intel 850: ok
  • Intel 815: crash
  • Intel 810: Does not work
  • Intel 82852/82855: Partial support, problems tilting
  • Intel 82915G/GV/910GL Express Chipset family: Partial support, problems tilting
  • Intel 82865G: Partial support, problems tilting, hangs in full screen mode
(As of 2005-06-22 Intel is aware of this and has "raised the issue to the engineering group")

SIS

SIS drivers can be found at www.sis.com

  • SIS 6##: Works with updated drivers from SIS, problems tilting, updating to World Wind to 1.3.2 has been reported to fix the tilting problem.
  • SIS 7##: Works with updated drivers from SIS, problems tilting
  • Just an update for those running with the same chip set I am. (SIS 710): SiS does not seem to have a video driver newer than 2002 on their site. However, they have put a newer driver version dated April 2004 on download.com [1]. Installing this newer driver did cure my problems running World Wind. -- Kenny (StarLost)
  • My 661fx chip still facing grave problems with tilting, though updated with resent driver from SIS site. -Ophir-
  • SIS Xabre: OK on Xabre 80 (with SiS Xabre Driver v3.10 and SiS Xabre Performance v3.57.53 Driver)
  • SIS M760 : OK ( with SIS UniVGA Driver 3.66 )

S3

S3 drivers can be found at www.s3graphics.com

  • S3 Virge: crash
  • S3 Prosavage: Partial support, problems tilting
  • S3 SuperSavage/IXC: Partial support, problems tilting
  • VIA/S3G UniChrome IGP Card: Support until zoom close...then crash.
  • VIA/S3G UniChrome Graphics: On open program the computer crashes
  • S3 Twister K integrated: Won't run
  • S3 Savage4: incompatible
  • SC ProsavageDDR :works but a bit slow
  • S3 Trio 3D: incompatible
  • S3G CLE266 (integrated into VIA EPIA M10000 Nehemiah Mini-ITX motherboard): Crashes

Matrox

Matrox drivers can be found at: http://www.matrox.com/ , Matrox user community: http://murc.ws/ Matrox has pledged support for the World Wind program, if you're having problems with a Matrox card, let us know here and Matrox will send us a card to test out the issues your having. You can also email Matt Mills

  • Matrox Parhelia: ok (performance might benefit from the experimental drivers available)
  • Matrox Millenium P650: ok, Crashes if worldwind is used multi-monitor.
  • Matrox G550: Partial Support, problems tilting, sometimes crashs in near view (1.3.2 on G550 freezes the OS !)
  • Matrox G450 32MB: ok, sometimes crashes in near view
  • Matrox G400 16MB: ok, sometimes crashes in near view
  • Matrox G200: unlikely to work
  • Matrox G200 Marvel: BSOD in near view

Other

  • VOLARI V3: Ok
  • XGI Volari: Doesn't appear to work
  • 3Dfx Voodoo : Not Compatible
  • PowerVR KYRO II: Partial support, problems tilting.
  • 3Dlabs wildcat vp760: Partial working, Using latest driver (w2k3010842.exe) on a win2000. Somelayer doesn't show (ex. Place name).
  • 3Dlabs Wildcat III 6110: Doesn't appear to work on XP. Driver ver.: 6.5.6.18_3/16/2004
  • 3Dlabs Wildcat 4 7110: Same as above. Driver: 6.6.2.60_3/5/2004
  • 3DLabs WildCat Realizm 200 - Works but no kind of acceleration - seems to be pure CPU performance.
  • Elsa Gloria II: Ok

External links

Check out the Video hardware compatibility list in the forum.

Sponsored by Vidahost webhosting and Thermal Degree web design.
Personal tools